<< Нажмите для отображения Оглавления >>

Навигация:  Вопросы и ответы > Ошибки >

Ошибка запроса к серверу активации 2

Исходная ситуация

 

При нажатии на кнопку Применить в диалоге Ключи КПК возникает ошибка

 

Ошибка запроса к серверу активации 0xНОМЕРОШИБКИ

Ошибка подключения к серверу активации 'SSL connect error'

 

Старые операционные системы Windows XP, Windows 2003, Windows 7 SP1 не могут расшифровать сертификат шифрования на котором работает Моби-С так как не поддерживают современные алгоритмы шифрования.

 

Решение

 

Вариант 1

 

Обновление операционной системы. Все проблемные ОС сняты с поддержки и нормальная работа в них не возможна.

 

Вариант 2

 

Активируйте лицензии на другом компьютере, с актуальной операционной системой, где работает кнопка Применить. Информация по активированным лицензиям храниться в файле lickeys.txt или lickeys_utf8.txt.

 

1.Запустить Моби-С на любом компьютере, где работает кнопка Применить.

2.Если основной каталог Моби-С сетевой, то достаточно активировать новое устройство на этом компьютере.

3.Если основной каталог Моби-С не сетевой, сделать сетевым и повторите пункты 2 и 3.

4.Если дата создания файла blacklist.bin больше 2 недель от текущей, то необходимо скачать файл по ссылке https://mobi-c.ru/components/com_licensing/blacklist2.bin

переименовать в blacklist.bin и положить в каталог Моби-с.

 

Вариант 3

 

 

Версия Моби-С 5.5

 

Специально для таких систем мы создали библиотеку PocketServer55.dll в которую интегрированы инструменты для работы с сертификатами.

 

Скачать библиотеку

 

Важно! Библиотека предназначена только для x86 версии клиента 1С.

 

В скачиваемый архив входят файлы:

PocketServer55.dll - библиотека.

Интеграция Моби-С с 1С 8 (5.4).epf - обработка для Моби-С версии 5.4 с внесенными доработками для конфигураций на базе Управление Торговлей 10.3. Для платформы 8.2 потребуется конвертация обработки.

ПрочтиМеня.txt - программный код изменений для обработки.

 

Что нужно сделать для замены библиотеки:

 

1.Поместить файл PocketServer55.dll в каталог bin в папке установленной платформы 1С на которой работает ваша конфигурация.
Пример: Для платформы 1С:Предприятие 8.2 (8.2.19.130) файл нужно переместить в каталог c:\Program Files (x86)\1cv82\8.2.19.130\bin\

2.Зарегистрировать из командной строки библиотеку PocketServer55.dll.

3.Перезапустить 1С и обработку. Проверить обмен с кпк агента.

 

Ошибка запроса к серверу активации 1

 

Версия Моби-С 5.4

 

Важно! Перед любыми операциями обновления настоятельно рекомендуем сделать резервную копию базы данных и основного каталога Моби-С.

 

1.Доработать обработку Моби-С

a.Изменилось имя серверной компоненты и сервера. Заменить везде PocketServer54.dll, AddIn.PocketServer54, AddIn.Server54 на PocketServer55.dll, AddIn.PocketServer55, AddIn.Server55.

b.Необходимо перевести файл ключей lickeys.txt на UTF-8 формат. Новый файл lickeys_utf8.txt.

2.Поместить файл PocketServer55.dll в каталог bin в папке установленной платформы 1С на которой работает ваша конфигурация.
Пример: Для платформы 1С:Предприятие 8.2 (8.2.19.130) файл нужно переместить в каталог c:\Program Files (x86)\1cv82\8.2.19.130\bin\

3.Зарегистрировать из командной строки библиотеку PocketServer55.dll.

4.Перезапустить 1С и обработку. Проверить обмен с кпк агента.

 

Доработка обработки для УТ 10.3

1) Доработка обработки Моби-С

Список изменений в типовой Моби-С 5.4.8 для работы с PocketServer55.dll

 

1) Модуль объекта

1.1) метод ОткрытьФайлOnLineКлючей

новая версия библиотеки работает с файлом ключей в кодировке UTF-8, старая версия обработки работала в Win-1251

было

   ПутьКФайлуКлючей=КаталогЛогФайлов+"\lickeys.txt";

стало

   ПутьКФайлуКлючей=КаталогЛогФайлов+"\lickeys_utf8.txt";

 

было

       ФайлКлючей.Прочитать(ПутьКФайлуКлючей);  

стало

       ФайлКлючей.Прочитать(ПутьКФайлуКлючей, КодировкаТекста.UTF8);  

 

1.2) Раздел основной программы

было

СервернаяКомпонента = "PocketServer54.dll";

ИмяСервернойКомпоненты = "AddIn.PocketServer54";

ИмяСервера = "AddIn.Server54";

 

стало

СервернаяКомпонента = "PocketServer55.dll";

ИмяСервернойКомпоненты = "AddIn.PocketServer55";

ИмяСервера = "AddIn.Server55";

 

2) Форма Ключи

новая версия библиотеки работает с файлом ключей в кодировке UTF-8, старая версия обработки работала в Win-1251

2.1) удалить метод ОткрытьФайлOnLineКлючей, будет использоваться метод МодульОбъекта.ОткрытьФайлOnLineКлючей

 

2.2) метод СохранитьOnLineКлючи

новая версия библиотеки работает с файлом ключей в кодировке UTF-8, старая версия обработки работала в Win-1251

было

   ПутьКФайлуКлючей=КаталогЛогФайлов+"\lickeys.txt";

   зт = новый ЗаписьТекста(ПутьКФайлуКлючей, "windows-1251");

стало

   ПутьКФайлуКлючей=КаталогЛогФайлов+"\lickeys_utf8.txt";

   зт = новый ЗаписьТекста(ПутьКФайлуКлючей, КодировкаТекста.UTF8);

 

3) форма ФормаОсновная

3.1) метод ПерезапускСервера

новая версия библиотеки работает с файлом ключей в кодировке UTF-8, старая версия обработки работала в Win-1251

было

       ПутьКФайлуКлючей=КаталогЛогФайлов+"\lickeys.txt";

       Ф=Новый Файл(ПутьКФайлуКлючей);

стало

       ПутьКФайлуКлючей=КаталогЛогФайлов+"\lickeys_utf8.txt";

       Ф=Новый Файл(ПутьКФайлуКлючей);

       Если не ф.Существует() Тогда

           зт = новый ЗаписьТекста(ПутьКФайлуКлючей, КодировкаТекста.UTF8);

           зт.Записать("# Редактирование этого файла вручную запрещено." + Символы.ПС);

           зт.Закрыть();

       КонецЕсли;

 

3.2) метод ПриОткрытии

отключаем проверку версии внешней компоненты и обработки

было

           Если Сервер.Версия() <> ВерсияPocketServer Тогда

               ТекстОшибки =

                   "Используется версия " + СервернаяКомпонента + " v." + Сервер.Версия()

                   + ". Для обработки требуется v." + ВерсияPocketServer;

               АвтономныйРежим = Истина;

           КонецЕсли;

стало

           //Если Сервер.Версия() <> ВерсияPocketServer Тогда

           //    ТекстОшибки =

           //        "Используется версия " + СервернаяКомпонента + " v." + Сервер.Версия()

           //        + ". Для обработки требуется v." + ВерсияPocketServer;

           //    АвтономныйРежим = Истина;

           //КонецЕсли;

 

новая версия библиотеки работает с файлом ключей в кодировке UTF-8, старая версия обработки работала в Win-1251

добавляем автоматическое преобразование файла ключей lickeys >> lickeys_utf8 при первом запуске

было

   Если НЕ РежимРабочееМесто Тогда

       Если НЕ АвтономныйРежим Тогда

стало

   ПутьКФайлуКлючей = КаталогЛогФайлов + "\lickeys.txt";

   ПутьКФайлуКлючейUTF8 = КаталогЛогФайлов + "\lickeys_utf8.txt";

   Ф = Новый Файл(ПутьКФайлуКлючей);

   фUTF = Новый Файл(ПутьКФайлуКлючейUTF8);

   Если фUTF.Существует() Тогда

   //ничего не делаем, ключи не объединяем

   Иначе              

       Если ф.Существует() Тогда

       //преобразуем в utf-8  

           файлКлючей = Новый ТекстовыйДокумент();

           файлКлючей.Прочитать(ПутьКФайлуКлючей);

           ФайлКлючей.Записать(ПутьКФайлуКлючейUTF8, КодировкаТекста.UTF8);  

       Иначе                  

           ФайлКлючей = Новый ТекстовыйДокумент();

           ФайлКлючей.УстановитьТекст("# Редактирование этого файла вручную запрещено.");

           ФайлКлючей.Записать(ПутьКФайлуКлючейUTF8, КодировкаТекста.UTF8);

       КонецЕсли;  

   КонецЕсли;

   Если НЕ РежимРабочееМесто Тогда

       Если НЕ АвтономныйРежим Тогда

 

новая версия библиотеки работает с файлом ключей в кодировке UTF-8, старая версия обработки работала в Win-1251

было ПутьКФайлуКлючей=КаталогЛогФайлов+"\lickeys.txt";

стало  ПутьКФайлуКлючей=КаталогЛогФайлов+"\lickeys_utf8.txt"

 

3.3) в методах ПриОткрытии и ОбработкаОповещения найти вызов метода Сервер.СоединениеСОблаком и удалить в вызове четвертый параметр

Сервер.СоединениеСОблаком(КодУчетнойСистемы,ПарольУчетнойСистемы, ИмяКомпьютера());

 

Доработка обработки для ТиС 9.2 (1С 7.7)

1) Заменить файл Регистрация ключей.ert

 

2) Внести изменения в файл ГлобальныйМодульМобиС.txt

 

2.1 В начале файла добавить переменую

Перем ВерсияДЛЛ;

 

2.2 Заменить строки

ОбъектPocketServer="AddIn.Server54";

СервернаяКомпонента = "PocketServer54.dll";

на

ОбъектPocketServer="AddIn.Server55";

СервернаяКомпонента = "PocketServer55.dll";

 

2.3 Найти этот код и заменить название переменной на ВерсияДЛЛ

 

 Если АвтономныйРежим = 0 Тогда

         Сервер=СоздатьОбъект(ОбъектPocketServer);

         Попытка

                 Если (Сервер.Версия() <> ВерсияДЛЛ) Тогда

                           Предупреждение("Вы используете устаревшую версию " +СервернаяКомпонента+"."+РазделительСтрок+"Свяжитесь с разработчиком для получение новой версии.");

                         

2.4 В конце файла добавить

ВерсияДЛЛ = "5.5";

 

3) В файл Интеграция Моби-С с 1С 7 (5.4).ert добавить функцию Функция ПреобразоватьСтрокуИзУТФ8(Стр)

 

Функция ПреобразоватьСтрокуИзУТФ8(Стр)

 Длина=СтрДлина(Стр);

 Итог="";

 Для Н=1 По Длина Цикл

 Знак=Сред(Стр,Н,1);

 Код=КодСимв(Знак);

 Если Код<128 Тогда

 Итог=Итог+Знак;

 ИначеЕсли (Код>=128)И(Код<192) Тогда

 Иначе

 Н=Н+1;

 Знак2=Сред(Стр,Н,1);

 Код2=КодСимв(Знак2);

 Если Код=208 Тогда

 Итог=Итог+Симв(КодСимв("А")+Код2-144);

 ИначеЕсли Код=209 Тогда

 Итог=Итог+Симв(КодСимв("р")+Код2-128);

 КонецЕсли;

 КонецЕсли;

 КонецЦикла;

 Возврат Итог;

КонецФункции